Google has cleared our email link-tracking domain and everything is back to normal. Links in all emails — including previously sent updates and reminders — work as expected, and email open and click tracking has been re-enabled.
A small number of users may briefly see a residual security warning while third-party security tools refresh their data; this clears automatically within a day or two and requires no action.
Thank you for your patience.
Posted Jul 13, 2026 - 18:14 UTC
Monitoring
Google has completed its review and removed the incorrect flag from our email link-tracking domain. Links in previously sent emails are working again.
Some browsers may continue to show a cached security warning for a short period (typically under an hour) while their Safe Browsing data refreshes. This clears automatically — no action is needed.
Email open and click tracking remains temporarily paused; emails deliver and links work normally, but engagement data is not being recorded. We will re-enable tracking once we've confirmed the warning has fully cleared for all users.
Posted Jul 13, 2026 - 15:06 UTC
Identified
Some recipients clicking links in Visible emails — including published Updates and update request reminders — currently see a browser security warning or the link fails to open.
Our email link-tracking domain was incorrectly flagged by Google Safe Browsing on July 13 (~03:00 UTC). This affects links in emails sent before approximately [07:00 UTC / 2:00 AM CT] today, when we deployed a workaround.
As part of that workaround, we have temporarily disabled email open and click tracking. Emails sent while tracking is disabled deliver and their links work normally, but opens and clicks for these emails will not appear in your update analytics.
The Visible application itself is fully operational, and all published updates remain accessible directly at visible.vc.
We have completed a security audit of our email infrastructure, found no harmful content, and have submitted a review request to Google to restore the flagged domain. Once the review completes, links in previously sent emails will work again and we will re-enable tracking.